SMTP-Einstellungen und Versand von E-Mails

Hallo sevDesk-Support-Team @Buesra_von_sevDesk @Eduard_von_sevDesk @Raphael_von_sevDesk @Anil_von_sevDesk @Saskia_von_sevDesk,

ich habe seit Wochen Probleme mit dem Versand von E-Mails über SevDesk! Meine Kunden erhalten keine Angebote, Rechnungen, etc.
Bisher habe ich keinen eigenen SMTP-Server hinterlegt, da es am Anfang gut funktioniert hat.
Nun ist es so, dass die Mails von den SPAM-Filtern bereits vor der Zustellung an das entsprechende Postfach rausgefischt werden, da der Score so hoch ist. Grund (sofern man unseren Filter vertraut) ist, der fehlende SPF-Record. Fehlermeldung: SPF not aligned (relaxed), DKIM not aligned (relaxed),reject]
Ich vermute auch Google, Web.de, Yahoo.com,… wird das gleiche melden.
Testweise habe ich auch mail.sevdesk.com als SPF-Record hinterlegt - ohne Erfolg!

Am Telefon wurde mir nun gesagt ich soll bitte my.sevdesk.de in meinem SPF-Record hinterlegen. Gesagt, getan, aber die Mails werden weiterhin blockiert. Ich war mir aber auch zu dem Zeitpunkt sicher, dass der Kollege am Telefon mir eine falsche Domain weitergegeben hat.

Dann nutze ich halt meinen eigenen Mailserver und konfiguriere SMTP in SevDesk.
Tja, das funktioniert aber nicht, da SevDesk nur TLS1.0 unterstützt und meine Daten nicht gespeichert werden können.
Ich stehe also jetzt ohne E-Mail-Versand da! Natürlich können wir tricksen und einen Maildienst wie Sendgrid (nutzt ihr für den Versand) einbinden, aber ich möchte es einfach haben und nicht noch mehr Geld für den Versand von Mails ausgeben!!!
Wäre euer Dienst kostenlos, hätte ich es sofort gemacht, aber ich bezahle euch für diese Funktionen!

Wie sieht nun die Lösung aus?
Habt ihr einen funktionierenden SPF-Record und idealerweise auch ein DKIM-Key für mich?
Unterstützt ihr neuere Technologien und ich kann meinen eigenen Mailserver anbinden?

Ich bitte um Antwort und den weiteren Schritten bis Freitag, 9.4. 13:00

Hallo @Vasiliki,

laut https://www.mail-tester.com/ haben wir einen ziemlich guten Score weshalb es mich wundert das deine Rechnungen nicht ankommen.

Da hast du Recht, die richtige Domain für den Versand ist:

Name: my.sevdesk.de
Adresse: 52.57.251.238

Wir haben vor kurzem auf TLS 1.2 geupdatet.

Viele Grüße,
Eduard

Hallo @Eduard_von_sevDesk,

vielen Dank für Deine Rückmeldung.
Ich vermute du bist kein IT-ler und dir fehlt hier ein bisschen Hintergrundwissen zum Thema Mails.

Ich versuche es einfach zu erklären:
Solange ich kein SMTP bei mir im Account hinterlegt habe, schickt ihr Mails über eure Domain in meinen Namen (bzw. im Namen meiner Domain). Wenn du dir die RAW-Mail anschaust wirst du das sehen.

[bounces@mail.sevdesk.com] invoice@meinedomain.de

Schicke ich also eine Mail über meinen SevDesk-Account an den Mailtester erhalte ich folgendes Ergebnis:


Da sieht der Score schon anders aus, nicht wahr?
Ich habe den von dir genannten Server nun in unserem DNS hinterlegt. In paar Stunden würde ich erneut testen.

Zum Thema SMTP:
Wenn ihr TLS 1.2 unterstützt, dann bin ich mal auf den Log gespannt. Warum akzeptiert ihr meine Einstellungen nicht? Warum zeigt SevDesk nur einen dummen Hinweis und nicht die genaue Fehlermeldung? Wie kann der User prüfen, was da falsch ist?
Ihr erhaltet vom Server die genaue Fehlermeldung und könnt diese 1:1 an den Kunden weitergeben.

Bitte schicke mir doch die Log-Ausgabe (wenn sensible Daten im Log enthalten sind, ausschließlich via Mail und nicht im Forum posten!!!).

2 „Gefällt mir“

@Eduard_von_sevDesk

Der angegebene DNS-Record funktioniert nicht. Diverse Tools melden Fehler mit der angegebenen Domain.

@Buesra_von_sevDesk @Eduard_von_sevDesk @Raphael_von_sevDesk @Anil_von_sevDesk @Saskia_von_sevDesk

Könnt ihr mir hierzu einen aktuellen Status mitteilen?

@Administratoren

Tut sich da noch was?

Hallo @Vasiliki,

ich warte derzeit auf Rückmeldung von unserer Entwicklung und gebe dir Bescheid sobald ich mehr weiß.

Viele Grüße,
Eduard

Ich habe leider das selbe Problem.

Blockquote

Analysis von hardenize.com

Included policy not found
*One of the included SPF policies could not be found. Because of it, the entire SPF policy is deemed invalid.
Missing policy location: o1.em.sevdesk.com

Blockquote

Hallo @Eduard_von_sevDesk
hast du mittlerweile die Rückmeldung?

Ist das euer Anspruch? Tickets ignorieren? Frustrierte Kunde im Forum zu haben?

@Soziokratie_Zentrum ,

hat sich gerade zurück gemeldet das es mit den folgenden Einstellungen funktioniert →

kannst du das bestätigen?

Viele Grüße,
Eduard

oje leider kommen Mails auch mit den neuen SPF Einstellungen nur ann wenn sie an Emailadressen unserer eigener Mitarbeiter gehen, Emails an externe Mailserver kommen nicht an! Bitte dringend testen und kontakt mit uns aufnehmen um das Problem zu lösen. Danke

1 „Gefällt mir“

@Eduard_von_sevDesk,

Könnt Ihr bitte einen aktuellen Status zu dem Thema geben und eventuell die Priorität hochsetzen?
Es ist schlicht und ergreifend nicht möglich einen SMTP Server in Verbindung mit O365/M365 einzurichten.
Das wäre absolut nötig da wir nach wie vor wie auch @Vasiliki geschrieben hat alle Mails im Spam vorfinden.

1 „Gefällt mir“

Ich kann dieses Problem reproduzieren! Mein derzeitiger Workaroud liegt darin, dass ich Angebote Rechungen etc. herunterlade und vom Mailclient versenden muss.

Hi!
Ich habe nicht allzu hohe Anforderungen an SevDesk aus Funktionssicht, aber wie kannst du damit leben?
Man hofft doch das ein so gut vermarktetes Buchhaltungstool auch Automatisierungen zur Entlastung unterstützt. Rechnungen/Angebote über das System zu versenden sollte da schon zu den Basics gehören.

@Eduard_von_sevDesk
Wie schaut es denn nun hierzu aus? Wenigstens etwas auf der Timeline?
Ebenso wie ein funktionierender Editor für Schriftarten/Signaturen etc.?

Beste Grüße
Daniel

Ich hab mittlerweile einen Workaround gefunden und verwende SendGrid zum Mailversand. Bis zu 100 Mails pro Tag sind kostenlos https://sendgrid.com/pricing/

Liebe Grüße
Michael

Hallo allerseits,

eigentlich wollte ich gerade einen eigenen Thread zu dem Thema öffnen, bin aber froh, diesen hier gefunden zu haben! Denn er bestätigt leider die Befürchtung, dass es beim Thema Mailversand, wie auch anderen Problemen (z.B. doppelte, wiederkehrende Transaktionen über die Bank-API) und anderen KO-Schlägen keine sinnvolle Abhilfe gibt.
Dass Sevdesk Sendgrid als Workaround oder Alternative zum Mailversand vorschlägt, weil die eigene Mail Engine bzw. SMTP Anbindung schlicht nicht funktioniert, spricht Bände.
Was macht ihr, wenn Sendgrid sich entscheidet, dass der Free Plan nun 5 € im Monat kostet? Dürfen dies eure Kunden dann an euch weiter berechnen?
5 Monate sind vergangen und es gibt hier noch keine Lösung, noch nicht mal ein Status Update. Seit Thread Erstellung sind es 12 Monate. Für ein Basic Feature.
Mir persönlich ist meine Zeit und mein Geld zu schade, weiterhin zahlender Betatester zu sein, denn ich schätze nicht, dass vor Ablauf meiner Kündigungsfrist an dem gezeigten „Commitment“, die Probleme nachhaltig zu beheben, sich irgendetwas ändern wird. Echt schade!

1 „Gefällt mir“

Hallo zusammen,

die korrekten Daten für einen SPF Record sind →

Lookup für die Domain:

mail.sevdesk.com

zu überprüfende IP-Adresse:

167.89.85.240

Wir haben mittlerweile unser SMTP Logging verbessert und im nächsten Rollout ändern wir das Verschlüsselungsfeld zu einem Dropdown damit hier klarer wird welche Verschlüsselungen wir unterstützen.

Viele Grüße,
Eduard

1 „Gefällt mir“

Die Info sollte am besten dort stehen, wo auch die Eingabe der Zugangsdaten stattfindet. Vielleicht sogar mit einem Abgleich, ob der SPF-Record korrekt eingerichtet ist, sofern nicht SMTP verwendet wird.

@Eduard_von_sevDesk

Hi zusammen,

SPF/DMARC funktioniert nun aber die SMTP Einstellungen bei SevDesk in Kombination mit Office365 wird einfach nichts.
Seitens O365 ist alles aktiviert, auch der User für SMTP freigeschaltet. Port und Angaben stimmen.

Könnt Ihr das bitte zeitnah prüfen. Das Thema ist nun schon eine ganze Weile offen und meiner Meinung nach gibt es immer noch keine zufriedenstellende Lösung.
Ein Workaround über 3rd Party Tools wie Sendgrid kommt definitiv nicht in Frage.

Was gemacht werden muss ist das ihr eine Browser basierte Authentifizierung einbauen müsstet. Basic Authentication wurde seitens Microsoft abgeschaltet und sollte nach Möglichkeit nicht aktiviert werden.
Ich habe es nun zum laufen bekommen mit nun eben dieser.

1 „Gefällt mir“

Hast du bei M365 die 2FA aktiviert? Steht diese am passen Benutzer/Eigentümer auf „erzwungen“ im MFA-Dashboard von M365? Hast du ein App-Passwort vergeben? @AwesomeA